Discussion:
Netzteil für Sun SS20
(zu alt für eine Antwort)
Michael Bäuerle
2019-04-03 08:40:13 UTC
Permalink
Hat jemand ein Netzteil für eine Sun SS20 (die SS5 hatte AFAIK das
gleiche Netzteil) übrig?

Bei meinem Exemplar ist der Transistor, der die Primärwicklung des
Trafos treibt, gestorben. Die Netzspannung auf dem Gate hat diverse
Widerstände ableben lassen, bis hin zu einem vergossenen Hybridmodul
"HBT062" welches die Primärseite steuert.
Marcel Mueller
2019-04-10 05:51:43 UTC
Permalink
Post by Michael Bäuerle
Hat jemand ein Netzteil für eine Sun SS20 (die SS5 hatte AFAIK das
gleiche Netzteil) übrig?
Bei meinem Exemplar ist der Transistor, der die Primärwicklung des
Trafos treibt, gestorben. Die Netzspannung auf dem Gate hat diverse
Widerstände ableben lassen, bis hin zu einem vergossenen Hybridmodul
"HBT062" welches die Primärseite steuert.
Die Sache mit dem gegrillten Hybridmodul ist blöd. Notfalls bekommt man
aber auch das wieder hin. Ich würde in so einem Fall die
Primärinduktivität ungefähr messen, daraus die Schaltfrequenz abschätzen
und dann einfach einen UC3842 o.ä. mit einem FET als Ersatz davor
hängen. Üblicherweise erfolgte die Regelung auch damals per Optokoppler.
Das bekommt man schon wieder hin. Einzig bei der Hilfswickling für die
Versorgung des Primärkreises muss man etwas aufpassen, welche Spannung
die liefert und ggf. den richtigen Chip nehmen.

Also falls sich da nichts auftreiben lässt, es gibt immer eine Lösung.


Marcel
Michael Bäuerle
2019-04-10 09:30:32 UTC
Permalink
Post by Marcel Mueller
Post by Michael Bäuerle
Hat jemand ein Netzteil für eine Sun SS20 (die SS5 hatte AFAIK das
gleiche Netzteil) übrig?
Bei meinem Exemplar ist der Transistor, der die Primärwicklung des
Trafos treibt, gestorben. Die Netzspannung auf dem Gate hat diverse
Widerstände ableben lassen, bis hin zu einem vergossenen Hybridmodul
"HBT062" welches die Primärseite steuert.
Die Sache mit dem gegrillten Hybridmodul ist blöd. Notfalls bekommt man
aber auch das wieder hin.
Noch ist nicht sicher, dass dieses Hybridmodul wirklich tot ist.
BTW: Es gibt noch eine Zusatzplatine mit einem weiteren Hybridmodul
"HBZ063" auf der Sekundärseite. Das ist sicher noch OK, die zugehörige
Platine bekommt aber auch neue Elkos.

Das aus dem Gehäuse herausgesprengte Stück des Transistors habe ich
wiedergefunden, wenn man es neben das Loch im Gehäuse hält kann man
die Bezeichnung rekonstruieren: Es war ein Fuji 2SK1944 MOSFET
(UDS=900V, ID,cont=5A, PD,max=100W, RDS,On,max = 2.8Ω, Ciss,max=1.8nF).
Als Ersatz habe ich einen Fairchild FQA6N90C_F109 vorgesehen
(UDS=900V, ID,cont=6A, PD,max=198W, RDS,On,max = 2.3Ω, Ciss,max=1.8nF).
Post by Marcel Mueller
Ich würde in so einem Fall die
Primärinduktivität ungefähr messen, daraus die Schaltfrequenz
abschätzen und dann einfach einen UC3842 o.ä. mit einem FET als Ersatz
davor hängen. Üblicherweise erfolgte die Regelung auch damals per
Optokoppler. Das bekommt man schon wieder hin. Einzig bei der
Hilfswickling für die Versorgung des Primärkreises muss man etwas
aufpassen, welche Spannung die liefert und ggf. den richtigen Chip
nehmen.
Das hässliche an der Sache ist, dass das HBT062 noch eine zweite
Primärendstufe steuert (einen Hitachi 2SK1168), es gibt auch zwei
Feedback-Pfade via Optokoppler (beide ausgehend von dem anderen Hybrid-
modul HBZ063). Außerdem hängt am primärseitigen Kühlkörper ein
Temperatursensor, der ist ebenfalls an das HBT062 angeschlossen.

Das HBT062 herauszunehmen, und durch einen Eigenbau zu ersetzen, würde
bedeuten, dass dieser sich um diese Teile ebenfalls kümmern müsste.
Platz für eine Zusatzplatine, die nur die defekte Endstufe steuert, ist
nicht wirklich vorhanden (deswegen schon original der Aufbau aus vier
Platinen und zwei Hybrid-Modulen).
Post by Marcel Mueller
Also falls sich da nichts auftreiben lässt, es gibt immer eine Lösung.
Ja, aber den Neubau des halben Netzteils wollte ich mir eigentlich
ersparen :-/
Michael Bäuerle
2019-05-03 12:13:17 UTC
Permalink
Post by Michael Bäuerle
Post by Marcel Mueller
Post by Michael Bäuerle
Hat jemand ein Netzteil für eine Sun SS20 (die SS5 hatte AFAIK das
gleiche Netzteil) übrig?
Bei meinem Exemplar ist der Transistor, der die Primärwicklung des
Trafos treibt, gestorben. Die Netzspannung auf dem Gate hat diverse
Widerstände ableben lassen, bis hin zu einem vergossenen Hybridmodul
"HBT062" welches die Primärseite steuert.
Die Sache mit dem gegrillten Hybridmodul ist blöd. Notfalls bekommt man
aber auch das wieder hin.
Noch ist nicht sicher, dass dieses Hybridmodul wirklich tot ist.
BTW: Es gibt noch eine Zusatzplatine mit einem weiteren Hybridmodul
"HBZ063" auf der Sekundärseite. Das ist sicher noch OK, die zugehörige
Platine bekommt aber auch neue Elkos.
Das aus dem Gehäuse herausgesprengte Stück des Transistors habe ich
wiedergefunden, wenn man es neben das Loch im Gehäuse hält kann man
die Bezeichnung rekonstruieren: Es war ein Fuji 2SK1944 MOSFET
(UDS=900V, ID,cont=5A, PD,max=100W, RDS,On,max = 2.8Ω, Ciss,max=1.8nF).
<Loading Image...>
Post by Michael Bäuerle
Als Ersatz habe ich einen Fairchild FQA6N90C_F109 vorgesehen
(UDS=900V, ID,cont=6A, PD,max=198W, RDS,On,max = 2.3Ω, Ciss,max=1.8nF).
Update:
Damit habe ich es nun wieder aufgebaut, neue Elkos und ein paar neue
Widerstände gab es auch noch:
<Loading Image...>
(eine ziemlich verbaute Angelegenheit wo man an nichts gut herankommt)

Es funktioniert aber noch nicht. Dieses Hybridmodul ist also wohl
ebenfalls gestorben:
<Loading Image...>
Post by Michael Bäuerle
[...]
Das HBT062 herauszunehmen, und durch einen Eigenbau zu ersetzen, würde
bedeuten, dass dieser sich um diese Teile ebenfalls kümmern müsste.
Platz für eine Zusatzplatine, die nur die defekte Endstufe steuert, ist
nicht wirklich vorhanden (deswegen schon original der Aufbau aus vier
Platinen und zwei Hybrid-Modulen).
Vergussmasse vorsichtig abgekratzt:
<Loading Image...>
Ich dachte zuerst an UCC5310, da passt aber das Pinout nicht
(und das ist auch kein JEDEC SOP-8 Gehäuse).
Die Verbindung zu den Widerständen RF5 und RF6 (beide hochohmig
geworden, einer hatte ein Loch) geht zu Pin 5. Das wird vermutlich
ein Fuji FA5310S sein.
Post by Michael Bäuerle
Post by Marcel Mueller
Also falls sich da nichts auftreiben lässt, es gibt immer eine Lösung.
Ja, aber den Neubau des halben Netzteils wollte ich mir eigentlich
ersparen :-/
In der Zwischenzeit habe ich ein anderes Netzteil bekommen (nochmal
Danke an meinen Namensvetter) mit dem die Maschine erstmal wieder
läuft.
Bernd Laengerich
2019-05-03 15:32:39 UTC
Permalink
Post by Michael Bäuerle
Die Verbindung zu den Widerständen RF5 und RF6 (beide hochohmig
geworden, einer hatte ein Loch) geht zu Pin 5. Das wird vermutlich
ein Fuji FA5310S sein.
Die RF sind Sicherungen (resistor fuse).

Bernd
Michael Bäuerle
2019-05-05 08:03:56 UTC
Permalink
Post by Bernd Laengerich
Post by Michael Bäuerle
Die Verbindung zu den Widerständen RF5 und RF6 (beide hochohmig
geworden, einer hatte ein Loch) geht zu Pin 5. Das wird vermutlich
ein Fuji FA5310S sein.
Die RF sind Sicherungen (resistor fuse).
Auf deutsch üblicherweise "Sicherungswiderstand" genannt.
Michael Bäuerle
2019-05-20 14:30:37 UTC
Permalink
Post by Michael Bäuerle
Post by Michael Bäuerle
Post by Marcel Mueller
Post by Michael Bäuerle
Hat jemand ein Netzteil für eine Sun SS20 (die SS5 hatte AFAIK das
gleiche Netzteil) übrig?
Bei meinem Exemplar ist der Transistor, der die Primärwicklung des
Trafos treibt, gestorben. Die Netzspannung auf dem Gate hat diverse
Widerstände ableben lassen, bis hin zu einem vergossenen Hybridmodul
"HBT062" welches die Primärseite steuert.
Die Sache mit dem gegrillten Hybridmodul ist blöd. Notfalls bekommt man
aber auch das wieder hin.
Noch ist nicht sicher, dass dieses Hybridmodul wirklich tot ist.
BTW: Es gibt noch eine Zusatzplatine mit einem weiteren Hybridmodul
"HBZ063" auf der Sekundärseite. Das ist sicher noch OK, die zugehörige
Platine bekommt aber auch neue Elkos.
Das aus dem Gehäuse herausgesprengte Stück des Transistors habe ich
wiedergefunden, wenn man es neben das Loch im Gehäuse hält kann man
die Bezeichnung rekonstruieren: Es war ein Fuji 2SK1944 MOSFET
(UDS=900V, ID,cont=5A, PD,max=100W, RDS,On,max = 2.8Ω, Ciss,max=1.8nF).
<http://micha.freeshell.org/tmp/2019-04-12_70_2SK1944.jpg>
Post by Michael Bäuerle
Als Ersatz habe ich einen Fairchild FQA6N90C_F109 vorgesehen
(UDS=900V, ID,cont=6A, PD,max=198W, RDS,On,max = 2.3Ω, Ciss,max=1.8nF).
Damit habe ich es nun wieder aufgebaut, neue Elkos und ein paar neue
<http://micha.freeshell.org/tmp/2019-04-12_95_PowerSupply.jpg>
(eine ziemlich verbaute Angelegenheit wo man an nichts gut herankommt)
Es funktioniert aber noch nicht. Dieses Hybridmodul ist also wohl
<http://micha.freeshell.org/tmp/2019-04-12_05_PCB_1879-1.jpg>
Post by Michael Bäuerle
[...]
Das HBT062 herauszunehmen, und durch einen Eigenbau zu ersetzen, würde
bedeuten, dass dieser sich um diese Teile ebenfalls kümmern müsste.
Platz für eine Zusatzplatine, die nur die defekte Endstufe steuert, ist
nicht wirklich vorhanden (deswegen schon original der Aufbau aus vier
Platinen und zwei Hybrid-Modulen).
<http://micha.freeshell.org/tmp/2019-04-12_10_PCB_1879-1.jpg>
Ich dachte zuerst an UCC5310, da passt aber das Pinout nicht
(und das ist auch kein JEDEC SOP-8 Gehäuse).
Die Verbindung zu den Widerständen RF5 und RF6 (beide hochohmig
geworden, einer hatte ein Loch) geht zu Pin 5. Das wird vermutlich
ein Fuji FA5310S sein.
Update:
Dem defekten IC habe ich alle Pins abgeschnitten und diese dann einzeln
freigekratzt und abgelötet. Danach wollte ich ihn mit der Zange her-
unterbrechen. Das hat nicht funktioniert und erst ein Schraubenzieher,
mit sanftem Hammerschlag darunter getrieben, hat ihn abgelöst:
<Loading Image...>

An den nun freiliegenden Pads ließ sich die vergossene Beschaltung ver-
messen und mit den Schaltungsbeispielen im Datenblatt vergleichen:
<Loading Image...>
Die zugehörigen SMD-Teile sahen gut aus.

Aus England konnte ich einen FA5310BS als Restposten beschaffen (mit
Gold aufgewogen):
<Loading Image...>
Damit läuft das Netzteil jetzt prinzipiell wieder -- es lässt sich ein-
und ausschalten und die Lüfter laufen. In der Maschine habe ich es noch
nicht getestet.

Loading...